
Chapter 23  File Management (FM)

Most Windows tasks involve working with and managing Files and Folders.Windows uses folders to
provide a storage system for the files on your computer, just as you use manila folders to organize in-
formation in a filing cabinet. A file is the way your computer contains all the electronic data that is
contained in a document whether it be a picture or text. In order to display the file on your monitor it
must copy it from its storage place to your RAM (Random Access Memory) where you use some type
of program to alter it. It also could have been created with the same program. You RAM sometimes
refereed to as just “Memory” is the only place files can be created or changed. Once you are finished
with it, it must be saved and stored again. It is usually stored on your hard drive, although it could be
saved to some other sort of storage media such as a floppy disk or CD.

All Files and Folders must have names and must be organized so that you can access or find them in
the quickest and easiest way possible. Learning to name and manage files is the backbone of the
knowledge you need to master the use of your computer. Let this be the beginning of your mastery.

Folders can contain many different types of files, such as documents, music, pictures, videos, and pro-
grams. You can copy and move files from other locations, such as another folder, computer, or the In-
ternet, to folders you create. You can even create folders within folders.

For example, if you are creating and storing files in the My Documents folder, you can make a new
folder within My Documents to contain the files. If you decide that you want to move the new folder
to a different location, you can easily move it and its contents by selecting the folder and dragging it
to the new location.

To open a file or folder that already exists or stored on your computer.

Open “My Documents” All files that you have created or saved to your computer should be stored in
the My Documents folder. If it is not then your are not properly saving your documents. You may
have saved the file within a sub-folder that you have created within My Documents.

If the file or folder you want to open is not located in My Documents or its subfolders, use Search to
find it. To open Search, click Start, and then click Search.

Once you have located it Double-click the file or folder you want to open. If you have found it out-
side of  My Documents then move it to My Documents.

If the file you want to open is not associated with a particular program, you can select one. To do so,
right-click the file, click Open With, and then select the name of the program. You can use the View
menu to change the way files are displayed. You can also use the View tab in the Folder Options dia-
log box to change file and folder settings. To open the Folder Options dialog box, on the Tools menu,
click Folder Options. See Chapter on File Association.

1



Moving a File

If the file or folder you want to move is not located in My Documents or its subfolders, use Search to
find it. Once you have found or located it, Highlight it by single clicking on it. Once highlighted all
actions apply to it.

Under File and Folder Tasks, click Move this file or Move this folder.

In Move Items, click the new location,  “MyDocuments,” for the file or folder, and then click Move.

To select and move a consecutive group of files, click the first file, press and hold down SHIFT, and
then click the last file. You can then handle the group like a single file. To select files or folders in
nonconsecutive order, press and hold down CTRL, and then click the items (highlight)you want.
You can also move a file or folder by dragging it from one open window to another. Open two sepa-
rate windows one for each folder. The one you are moving the file “from.” The other you are moving
it “to.” Drag the file by clicking and holding the left button down from the “From” window and drag
it to the “to” window. Make sure the “to” window is the correct window. The title bar at the top will
show the name of the folder.

The quickest and easiest way to handle a file is to highlight the file or files and then use the actions
from the “File and Folder Tasks” box shown below on the left. Choose the “Move this File” and a
window (shown below) will appear for you to choose “where” it is to be moved to. Click on “Move”
and it (they)will move there.

If you have sub folders in your My Documents
folder you can display them by clicking the
“plus” box just to the left of the folder icon. If
you highlight or select the sub-folder it will
move it there.

• Move and Copy will show this Window.
• Rename will allow to rename on the spot.
• e.mail will open your e-mail program and

create an e-mail message.
• Publish to the Web begins the Publishing

Wizard.
• Print will send to printer and print the file.
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Naming and Re-naming Files

Document Files are always named initially when they are created from the program that creates it.
When you proceed with saving it or closing an unsaved document (file) you will always be
prompted to giving it a name and saving it to a specific location. Not all programs automatically
save files to the My Documents folder. This is where you have to watch or be aware as to the loca-
tion where files are being saved. You also have to be aware of the name being given. If you save it
and do not name it , it will save it to a default name like “Document 1.”  If you are saving pictures,
like from your camera,  and do not name it, it will save it with a name like 010200405 which is a
date 10/20/04 picture #5.

Certain characters cannot be used in file names. they are:    \ / : * ? " < > |.
Some programs cannot interpret long file names. The limit for programs that do not support long file
names is eight characters. If the is no 8 character limit then the limit is 128 characters.

You can also rename a file or folder by right-clicking it and then clicking Rename. The names of
system folders such as Documents and Settings, Windows, or System32 cannot be changed. They
are required for Windows to run properly. Learn to keep all of your created documents and Files in
your My Document folders. Do not be afraid to create sub-folders but keep them within the My
Documents folder. If you do this religiously, you will never loose a file.

Save and SaveAs

When you are saving a document you must to be-
tween Save and SaveAs. You are not promoted to
choose between the two. You must know which
one to use as they are two different functions and
make a big difference which one you choose.

Save means to save the changes that you have
made to the existing file that is already saved and
named. The saving you make saves the file as you
have changed it but not the name. It does save the
current date of the file making it appear as it was
created this date of change. It also saves it in the
same folder from which you opened it.

SaveAs prompts you to name the file you are sav-
ing and the location for it. It is now attempting to
save the same file with the changes you made as a
different file with a different name without disturb-
ing the original file. As long as the new file has a
different name both files will be saved at the same
location or a new location that you must designate.
If your keep the same name you will be prompted
to overwrite the original if it is in the same location
(Folder). If you save the same name file to another
location (folder) it will allow the same name.
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The quickest and easiest way to rename a file is to rename it at its access location. If you already
have the file highlighted you can click on it a second time (there must be at least a 2 second pause be-
tween clicks) and a flashing cursor will appear in a text box around the file name. You are now able
to type in the name change. By clicking outside the box the name change is saved. If you violate any
file name rules, the change will not be saved.

Another way to change a files name is to right click on the file and select rename from the menu and
follow the same procedure. The are many ways to change file names. Regardless of what method you
use to rename a file it always displays the file listing within a text box allowing you to type the new
name as if you were using a word processor. Folder names are changed the same way.

Deleting Files is almost the same as other file functions with a few additional rules. Click and high-
light the file or folder you want to delete.

1. From the File and Folder Tasks box, click Delete this file or Delete this folder.

2. You can also delete files or folders by right-clicking the file or folder and then clicking Delete.
3. While the File or Folder is highlighted use your delete key on your keyboard.
4. All Files are never erased from your computer they are just moved to the Recycle Bin giving you

an opportunity to retrieve them.
5. To retrieve a file you have deleted, double-click the Recycle Bin icon on your desktop.

Folder Views. Windows provides several new ways for you to arrange and identify your files when
viewing them  . . .Filmstrip, Thumbnails, Tiles, Icons, Lists, Details. Select a folder view by clicking
on the View Menu on the Menu Bar at the top of your screen. The second section of the menu dis-
plays the list of different views. Each view is displayed on the next page. You may have a favorite
view that works best for you.
When you select a view it applies to this folder only. To make all folder views the same open you
must

When a folder is open, you can access each of the following view options on the View menu.

1. Show in Groups allows you to group your files by any detail of the file, such as name, size, type,
or date modified. For example, if you group by file type, image files appear in one group, Mi-
crosoft Word files appear in another group, and Excel files in another. Show in Groups is avail-
able in the Thumbnails, Tiles, Icons, and Details views. To show your files in groups, on the View
menu, point to Arrange Icons by, and then click Show in Groups.
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2. Thumbnails view displays the images a folder contains on a folder icon so you can quickly iden-
tify the contents of the folder. For example, if you store pictures in several different folders, in
Thumbnails view, you can tell at a glance which folder contains the pictures you want.Windows
displays up to four images on a folder background, by default. Or, you can choose one picture to
identify a folder in Thumbnails view. The complete folder name is displayed under the thumbnail.

3. Tiles view displays your files and folders as icons. The icons are larger than those in Icon view,
and the sort information you select is displayed under the file or folder name. For example, if you
sort your files by type, "Microsoft Word document" appears under the file name for a Microsoft
Word document.

4. Filmstrip view is available in picture folders. Your pictures appear in a single row of thumbnail
images. You can scroll through your pictures using the left and right arrow buttons. If you click a
picture, it is displayed as a larger image above the other pictures. To edit, print, or save the image
to another folder, double-click the picture.

5. Icons view displays your files and folders as icons. The file name is displayed under the icon;
however, sort information is not displayed. In this view you can display your files and folders in
groups.

6. List view displays the contents of a folder as a list of file or folder names preceded by small icons.
This view is useful if your folder contains many files and you want to scan the list for a file name.
You can sort your files and folders in this view; however, you cannot display your files in groups.

7. In Details view, Windows lists the contents of the open folder and provides detailed information
about your files, including name, type, size, and date modified. In Details view you can also show
your files in groups.To choose the details you want to display, on the View menu, click Choose
Details.

To make all folder views the same. . Open a folder and select a folder view.

On the Tools menu (Menu Bar at top of Window), click Folder Options.

On the View tab, click Apply to All Folders.

To reset all folders to the settings that were in effect when Windows XP was installed, click Reset

Thumbnails ViewTiles View
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Icons View List View

Details View Arranged in Groups by Type

To sort items by categories such as date, name, size, and type, on the View menu, point to Ar-
range Icons by, and then click the appropriate command.

In Details view, you can choose the file information you want to display. On the View menu, click
Choose Details. Use the Choose Details dialog box to select and organize the information that is
displayed.
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Personal Folders My Documents is your personal folder. It contains two specialized per-
sonal folders, My Pictures and My Music. You can make your personal folders available to each per-
son with a user account on this computer, or you can make them private so that only you can access
the files within them.

Windows creates personal folders for every user on the computer. When there is more than one per-
son using the computer, each personal folder is identified by the user's name. For example, if John
and Jane use the same computer, there will be two sets of personal folders: John's Documents, Music,
and Pictures, and Jane's Documents, Music, and Pictures. When John is logged on to the computer,
his personal folders appear as My Documents, My Pictures, and My Music, and Jane's appear as
Jane's Documents, Jane's Pictures, and Jane's Music.

Windows also provides a Shared Documents folder for files you want to share with other users. Like
My Documents, the Shared Documents folder contains a Shared Pictures and Shared Music folder.
These folders are for pictures and music you want to share with other people who use your computer.

Windows Explorer is a very popular file manager. If you are very confident with control of your
mouse with your drag and drop abilities the Windows Explorer File Manager is much quicker and
provides a better overview of your file system. Moving and manipulating files and folders with Win-
dows explorer is very dangerous for newbees and users with mouse problems because they have a
tendency to drop files in the wrong places thus loosing them. I therefore suggest you stay with My
computer to manage files because it opens a new window for each file access. The dragging an drop-
ping of files between locations is from one window to another rather than a to a tiny folder icon. with
the use to access your personal folders or the Shared Documents, Music, and Pictures folders.

To open Windows Explorer, click Start, point to All Programs, point to Accessories, and then click
Windows Explorer.

A View of Windows Explorer File Manager
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